Peer Client db version is lower than local – UCS FI cluster error

My colleagues have been facing this particular error recently when working on the Converged Infrastructure (Vblock, VxBlock etc) that when trying to check the FI Cluster state, it gives an error ” Peer Client db version is lower than local, self version: 3, peer version: 1″ when SSH into the FI Cluster IP address. The screen shot is as shown below:

ucs_ha_error

There are at least two resolutions which have worked so far with this kind of error on the FI Cluster

Resolutions

  1. Reboot the Peer FI (In the above case it was FI B (Subordinate)) so the database on FI B sync up with the FI A, Once FI B comes up, it will be in sync with FI A and the cluster state will be HA ready.
  2. SSH to the cluster IP, connect local-mgmt A (whichever is the primary), then do Cluster lead B (or whichever is subordinate), This will Failover the UCS Management service from Primary to Subordinate. This is a less Impactful method than the first method.
  3. restart pmon service on the peer FI (A/B) and this could fix the issue

Let me know if you come across any solutions to this issue.

Advertisements

Nutanix on UCS C-Series Rack Servers

As of 8/18/2016 Nutanix (as far as I know), Nutanix started selling its platform (Acropolis Hypervisor and Prism Software) on Cisco UCS C-series servers. Nutanix now supports the following UCS ¬†servers —

  • C220-M4S
  • C240-M4L
  • C240-M4SX

Looks like the Nutanix Software bundle comes in Acropolis Pro and Ultimate Editions.

More info to follow ….

Reference: Nutanix Website